2 flat logo on transparent 256
2018-09-25

Mac+rbenvでRubyの2.4系をインストールする手順

313212 20190925

Railsを4系から5系にアップデートする際にRubyもRuby 2.2.2系以上に上げる必要があります。

今回はMac+rbenvでRubyのバージョンを2.4系にインストールを行う方法を解説します。

rbenvでインストール利用可能なRubyのバージョンを確認する

rbenv install -l

ここでインストールしたいrubyのバージョンがない場合は Home brew と ruby-buildのアップデートを行います

brew update
brew upgrade ruby-build

インストールしたいRubyを指定

今回はRubyの2.4.1を指定

rbenv install 2.4.1

通常利用するRubyを指定

rbenv global 2.4.1

rbenv versionsで指定バージョンが表示されているか確認

rbenv versions
  system
* 2.4.1 

以上

前の記事
次の記事