2 flat logo on transparent 256
2019-03-31
2019-03-31

benv: bundle: command not found The `bundle' command exists

2019 03 31 programming21

Rubyを2.1系から2.4系に上げようとしたら 以下エラーが発生しました

bundleコマンドエラー

以下エラーのようにそもそもbundleコマンドが利用できないというエラーが発生しました

benv: bundle: command not found 
The `bundle' command exists 

Rubyはバージョン毎にgemが管理されており、bundlerもインストールする必要があります。

Rubyのbundleエラーの解決策

単純に bundlerをインストールします。

gem install bundler

これでbundlerがインストールされるので、bundleコマンドが利用可能になります。

rubyバージョンの際に自動でgemもアップデートしてくれる Ruby gem rbenv-default-gemsというものもあります。

頻繁にバージョンアップされる際は利用されてもよいかもしれません。

その他関連記事

RailsのエラーActiveRecord::ConnectionNotEstablished No connection pool

もう迷わない!WEBサイト配色の3ステップ

Rubyでサイトをスクレイピングし、ローカルに画像を保存する

前の記事
次の記事
人気記事
カテゴリーから記事を探す